NCTAudioInformation2Lib

NCTAudioStudio2 ActiveX DLLs
NCTAudioInformation2 ActiveX DLL

Version 2.2

NCTAudioInformation2 ActiveX DLL allows to edit information tags in an audio file.

With NCTAudioInformation2 you can:

  • Create and edit extra user information (tags) in audio files. WAV, OGG, MP3, MP2 and MP+ tags can be processed. For more information see the infoTrack, infoTitle, infoArtist, infoAlbum, infoYear, infoGenreS, infoComments, infoComposer, infoCopyright, infoURL and infoEncodedBy properties;

  • Insert and delete cues (markers) in audio files. This information can be saved only with WAV files that have RIFF file structure. For more information see the cueXXX properties;

  • Get general information about audio files and audio tracks of AVI files such as: audio format, bitrate, audio sample size (number of bits per sample), channels, audio sample rate (frequency), number of samples, time duration and size. For more information see the FormatTag, FormatString, Bitrate, BitsPerSample, Channels, Frequency, Samples, Duration and Size properties.

There is a category of audio files that have no header or any extra user information. Thus it is impossible to define their parameters (audio format, bit rate and etc.) automatically. You should know them or pick the parameters experimentally. It is always necessary to use the SetFormatXXX methods (NCTAudioFile) to operate RAW, G.721, G.723, G.726 and VOX files, because these files do not have any header. The SetFormatXXX methods specify not only the OUTPUT files' format, but the INTPUT files' format too.

NCTAudioInformation2 is a part of the NCTAudioStudio2 package.

Send Feedback on the NCTAudioInformation2 documentation.
NCTAudioInformation2 was developed by NCT company http://www.nctsoft.com


AudioInformation2 properties

AudioInformation2 properties

Property | Type | Default | Description
Bitrate | Long |  | Read-only property that returns the bitrate of an audio file.
BitsPerSample | Long |  | Read-only property that returns the number of bits per sample for the FormatTag format type.
Channels | Long |  | Read-only property that returns the number of channels of an audio file. Mono data uses one channel and stereo data uses two channels.
cueCodePage | Integer |  | Gets or sets the code page for cue list.
cueCount | Long |  | Read-only property that returns the number of cue points in the audio file.
cueCountry | Integer |  | Gets or sets the country code for the cue list.
cueDialect | Integer |  | Gets or sets the dialect for the cue list.
cueLabel | String |  | Gets or sets label field of the current cue point in the audio file.
cueLanguage | Integer |  | Gets or sets the Language code for the cue list.
cueLength | Long |  | Gets or sets the length of the current cue point in the cue list in the audio file.
cueNote | String |  | Gets or sets note field in the current cue point in the audio file.
cueNum | Long |  | Gets or sets the number of the current cue point.
cuePosition | Long |  | Gets or sets the position of the current cue point in the cue list in the audio file.
cueText | String |  | Gets or sets text field for the current cue point in the audio file.
Duration | Long |  | Read-only property that returns the duration of the audio file.
FormatString | String |  | Read-only property that returns the string with information about the audio file format.
FormatTag | Long |  | Read-only property that returns the waveform-audio format type of a WAV file.
Frequency | Long |  | Read-only property that returns the frequency of the audio file.
infoAlbum | String |  | Gets or sets the string with the album name, which contains the audio file subject.
infoArtist | String |  | Gets or sets the string with the name of the artist who created the original subject of the file. If there are many artists, the names are separated by a semicolon and a blank.
infoComments | String |  | Gets or sets the string with general comments about the audio file or the audio file subject.
infoComposer | String |  | Gets or sets the string with the name of the composer who created the original music of the file.
infoCopyright | String |  | Gets or sets the string with the copyright information of the audio file.
infoEncodedBy | String |  | Gets or sets the string with information about the encoder.
infoGenre | Integer |  | Gets or sets the genre number or classification string number of the audio file.
infoGenreS | String |  | Gets or sets the genre or classification string of the audio file.
infoOriginalArtist | String |  | Gets or sets the string with the name of the artist who created the original subject of the file. If there are many artists, the names are separated by a semicolon and a blank.
infoTitle | String |  | Gets or sets the string with the title of the audio file's subject.
infoTrack | String |  | Gets or sets the number of track of the audio file's subject.
infoURL | String |  | Gets or sets the URL of the audio file's subject.
infoYear | Long |  | Gets or sets the year when the audio file subject was created.
mp3FastAnalysis | Boolean |  | Gets or sets a flag indicating if fast MP3 analysis is enabled or not.
mp3TagInfoVersion | Integer |  | Gets or sets the version of an MP3 audio file.
Samples | Long |  | Read-only property that returns the number of samples in an audio file.
Size | Long |  | Read-only property that returns the size of an audio file.
Type | Integer |  | Read-only property that returns the type of an audio file.
WmaFormatEnabled | Boolean |  | Gets or sets a flag indicating if WMA format is enabled or not.

Send Feedback on the NCTAudioInformation2 documentation.
NCTAudioInformation2 was developed by NCT Company Ltd. http://www.nctsoft.com


Bitrate property (AudioInformation2)

Bitrate property (AudioInformation2)

Read-only property that returns the bitrate of an audio file.

Property type

A Long value.

Syntax

value = object.Bitrate

The Bitrate property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Long | The bitrate in bps (bits per seconds) of the audio file.

Example:

' VB sample where Info is an AudioInformation2 object.
infoFormatString.Text = Info.FormatString
infoFrequency.Text = Info.Frequency & " Hz"
infoBitrate.Text = Info.Bitrate & " bps"
infoDuration.Text = Info.Duration & " ms"
infoChannels.Text = Info.Channels
infoSamples.Text = Info.Samples
infoSize.Text = Info.Size
infoBitsPerSample.Text = Info.BitsPerSample
infoFormatTag.Text = Info.FormatTag

See Also:

BitsPerSample | Channels | Duration | FormatString | FormatTag | Frequency | Samples | Size | Type

Applies to: AudioInformation2


BitsPerSample property (AudioInformation2)

BitsPerSample property (AudioInformation2)

Read-only property that returns the number of bits per sample for the FormatTag format type.

Property type

A Long value.

Syntax

value = object.BitsPerSample

The BitsPerSample property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Long | If the FormatTag is WAVE_FORMAT_PCM, then BitsPerSample should be equal to 8 or 16. For the non-PCM formats, this number must be set according to the manufacturer's specification of the format tag. Note that some compression schemes cannot define a value for BitsPerSample, so this value can be zero.

Example:

' VB sample where Info is an AudioInformation2 object.
infoFormatString.Text = Info.FormatString
infoFrequency.Text = Info.Frequency & " Hz"
infoBitrate.Text = Info.Bitrate & " bps"
infoDuration.Text = Info.Duration & " ms"
infoChannels.Text = Info.Channels
infoSamples.Text = Info.Samples
infoSize.Text = Info.Size
infoBitsPerSample.Text = Info.BitsPerSample
infoFormatTag.Text = Info.FormatTag

See Also:

Bitrate | Channels | Duration | FormatString | FormatTag | Frequency | Samples | Size | Type


Channels property (AudioInformation2)

Channels property (AudioInformation2)

Read-only property that returns the number of channels of an audio file. Mono data uses one channel and stereo data uses two channels.

Property type

A Long value.

Syntax

value = object.Channels

The Channels property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Long | The number of channels of an audio file

Example:

' VB sample where Info is an AudioInformation2 object.
infoFormatString.Text = Info.FormatString
infoFrequency.Text = Info.Frequency & " Hz"
infoBitrate.Text = Info.Bitrate & " bps"
infoDuration.Text = Info.Duration & " ms"
infoChannels.Text = Info.Channels
infoSamples.Text = Info.Samples
infoSize.Text = Info.Size
infoBitsPerSample.Text = Info.BitsPerSample
infoFormatTag.Text = Info.FormatTag

See Also:

Bitrate | BitsPerSample | Duration | FormatString | FormatTag | Frequency | Samples | Size | Type


cueCodePage property (AudioInformation2)

cueCodePage property (AudioInformation2)

Gets or sets the code page for cue list.

Property type

An Integer value.

Syntax

object.cueCodePage [= value]

The cueCodePage property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Integer | The code page for cue list.

Remarks:

This field is used for information about the language of the text and is typically used for queries to obtain information from the operating system.

You can insert a cue point in the cue list in the audio file by the InsertCue method and delete by the DeleteCue method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.InsertCue 100, 40, "Label1", "Note1", "Text1", "Language1", "Country1", "Dialect1", 1
Info.cueNum = Info.cueCount
Info.cueCodePage = 2
Info.cueCountry = "Country2"
Info.cueDialect = "Dialect2"
Info.cueLabel = "Label2"
Info.cueLanguage = "Language2"
Info.cueLength = 44
Info.cueNote = "Note2"
Info.cuePosition = 144
Info.cueText = "Text2"

See Also:

InsertCue | cueCount | cueCountry | cueDialect | cueLabel | cueLanguage | cueLength | cueNote | cueNum | cuePosition | cueText | DeleteCue

Apples To: AudioInformation2


cueCount property (AudioInformation2)

cueCount property (AudioInformation2)

Read-only property that returns the number of cue points in the audio file.

Property type

A Long value.

Syntax

[value = ] object.cueCount

The cueCount property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Long | The number of cue points in the audio file.

Remarks:

You can insert a cue point in the cue list in the audio file by the InsertCue method and delete by the DeleteCue method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.InsertCue 100, 40, "Label1", "Note1", "Text1", "Language1", "Country1", "Dialect1", 1
Info.cueNum = Info.cueCount
Info.cueCodePage = 2
Info.cueCountry = "Country2"
Info.cueDialect = "Dialect2"
Info.cueLabel = "Label2"
Info.cueLanguage = "Language2"
Info.cueLength = 44
Info.cueNote = "Note2"
Info.cuePosition = 144
Info.cueText = "Text2"

See Also:

InsertCue | cueCodePage | cueCountry | cueDialect | cueLabel | cueLanguage | cueLength | cueNote | cueNum | cuePosition | cueText | DeleteCue


cueCountry property (AudioInformation2)

cueCountry property (AudioInformation2)

Gets or sets the country code for the cue list.

Property type

An Integer value.

Syntax

object.cueCountry [= value]

The cueCountry property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Integer | The country code for the cue list.

Remarks:

This field is used for information about the location of the text and is typically used for queries to obtain information from the operating system.

You can insert a cue point in the cue list in the audio file by the InsertCue method and delete by the DeleteCue method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.InsertCue 100, 40, "Label1", "Note1", "Text1", "Language1", "Country1", "Dialect1", 1
Info.cueNum = Info.cueCount
Info.cueCodePage = 2
Info.cueCountry = "Country2"
Info.cueDialect = "Dialect2"
Info.cueLabel = "Label2"
Info.cueLanguage = "Language2"
Info.cueLength = 44
Info.cueNote = "Note2"
Info.cuePosition = 144
Info.cueText = "Text2"

See Also:

InsertCue | cueCodePage | cueCount | cueDialect | cueLabel | cueLanguage | cueLength | cueNote | cueNum | cuePosition | cueText | DeleteCue


cueDialect property (AudioInformation2)

cueDialect property (AudioInformation2)

Gets or sets the dialect for the cue list.

Property type

An Integer value.

Syntax

object.cueDialect [= value]

The cueDialect property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Integer | The dialect for the cue list.

Remarks:

This field is used to specify information about the language used by the text and are typically used for queries to obtain information from the operating system.

You can insert a cue point in the cue list in the audio file by the InsertCue method and delete by the DeleteCue method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.InsertCue 100, 40, "Label1", "Note1", "Text1", "Language1", "Country1", "Dialect1", 1
Info.cueNum = Info.cueCount
Info.cueCodePage = 2
Info.cueCountry = "Country2"
Info.cueDialect = "Dialect2"
Info.cueLabel = "Label2"
Info.cueLanguage = "Language2"
Info.cueLength = 44
Info.cueNote = "Note2"
Info.cuePosition = 144
Info.cueText = "Text2"

See Also:

InsertCue | cueCodePage | cueCount | cueCountry | cueLabel | cueLanguage | cueLength | cueNote | cueNum | cuePosition | cueText | DeleteCue


cueLabel property (AudioInformation2)

cueLabel property (AudioInformation2)

Gets or sets label field of the current cue point in the audio file.

Property type

A String value.

Syntax

object.cueLabel [= value]

The cueLabel property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | String | The current cue point in the audio file.

Remarks:

You can insert a cue point in the cue list in the audio file by the InsertCue method and delete by the DeleteCue method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.InsertCue 100, 40, "Label1", "Note1", "Text1", "Language1", "Country1", "Dialect1", 1
Info.cueNum = Info.cueCount
Info.cueCodePage = 2
Info.cueCountry = "Country2"
Info.cueDialect = "Dialect2"
Info.cueLabel = "Label2"
Info.cueLanguage = "Language2"
Info.cueLength = 44
Info.cueNote = "Note2"
Info.cuePosition = 144
Info.cueText = "Text2"

See Also:

InsertCue | cueCodePage | cueCount | cueCountry | cueDialect | cueLanguage | cueLength | cueNote | cueNum | cuePosition | cueText | DeleteCue


cueLanguage property (AudioInformation2)

cueLanguage property (AudioInformation2)

Gets or sets the Language code for the cue list.

Property type

An Integer value.

Syntax

object.cueLanguage [= value]

The cueLanguage property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Integer | The Language code for the cue list.

Remarks:

This field is used to specify information about the language used by the text and are typically used for queries to obtain information from the operating system.

You can insert a cue point in the cue list in the audio file by the InsertCue method and delete by the DeleteCue method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.InsertCue 100, 40, "Label1", "Note1", "Text1", "Language1", "Country1", "Dialect1", 1
Info.cueNum = Info.cueCount
Info.cueCodePage = 2
Info.cueCountry = "Country2"
Info.cueDialect = "Dialect2"
Info.cueLabel = "Label2"
Info.cueLanguage = "Language2"
Info.cueLength = 44
Info.cueNote = "Note2"
Info.cuePosition = 144
Info.cueText = "Text2"

See Also:

InsertCue | cueCodePage | cueCount | cueCountry | cueDialect | cueLabel | cueLength | cueNote | cueNum | cuePosition | cueText | DeleteCue


cueLength property (AudioInformation2)

cueLength property (AudioInformation2)

Gets or sets the length of the current cue point in the cue list in the audio file.

Property type

A Long value.

Syntax

object.cueLength [= value]

The cueLength property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Long | The length of the current cue point in the cue list in the audio file.

Remarks:

You can insert a cue point in the cue list in the audio file by the InsertCue method and delete by the DeleteCue method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.InsertCue 100, 40, "Label1", "Note1", "Text1", "Language1", "Country1", "Dialect1", 1
Info.cueNum = Info.cueCount
Info.cueCodePage = 2
Info.cueCountry = "Country2"
Info.cueDialect = "Dialect2"
Info.cueLabel = "Label2"
Info.cueLanguage = "Language2"
Info.cueLength = 44
Info.cueNote = "Note2"
Info.cuePosition = 144
Info.cueText = "Text2"

See Also:

InsertCue | cueCodePage | cueCount | cueCountry | cueDialect | cueLabel | cueLanguage | cueNote | cueNum | cuePosition | cueText | DeleteCue


cueNote property (AudioInformation2)

cueNote property (AudioInformation2)

Gets or sets note field in the current cue point in the audio file.

Property type

A String value.

Syntax

object.cueNote [= value]

The cueNote property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | String | The current cue point in the audio file.

Remarks:

You can insert a cue point in the cue list in the audio file by the InsertCue method and delete by the DeleteCue method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.InsertCue 100, 40, "Label1", "Note1", "Text1", "Language1", "Country1", "Dialect1", 1
Info.cueNum = Info.cueCount
Info.cueCodePage = 2
Info.cueCountry = "Country2"
Info.cueDialect = "Dialect2"
Info.cueLabel = "Label2"
Info.cueLanguage = "Language2"
Info.cueLength = 44
Info.cueNote = "Note2"
Info.cuePosition = 144
Info.cueText = "Text2"

See Also:

InsertCue | cueCodePage | cueCount | cueCountry | cueDialect | cueLabel | cueLanguage | cueLength | cueNum | cuePosition | cueText | DeleteCue


cueNum property (AudioInformation2)

cueNum property (AudioInformation2)

Gets or sets the number of the current cue point.

Property type

A Long value.

Syntax

object.cueNum [= value]

The cueNum property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Long | The number of the current cue point.

Remarks:

You can insert a cue point in the cue list in the audio file by the InsertCue method and delete by the DeleteCue method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.InsertCue 100, 40, "Label1", "Note1", "Text1", "Language1", "Country1", "Dialect1", 1
Info.cueNum = Info.cueCount
Info.cueCodePage = 2
Info.cueCountry = "Country2"
Info.cueDialect = "Dialect2"
Info.cueLabel = "Label2"
Info.cueLanguage = "Language2"
Info.cueLength = 44
Info.cueNote = "Note2"
Info.cuePosition = 144
Info.cueText = "Text2"

See Also:

InsertCue | cueCodePage | cueCount | cueCountry | cueDialect | cueLabel | cueLanguage | cueLength | cueNote | cuePosition | cueText | DeleteCue


cuePosition property (AudioInformation2)

cuePosition property (AudioInformation2)

Gets or sets the position of the current cue point in the cue list in the audio file.

Property type

A Long value.

Syntax

object.cuePosition [= value]

The cuePosition property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Long | The position of the current cue point in the cue list in the audio file.

Remarks:

You can insert a cue point in the cue list in the audio file by the InsertCue method and delete by the DeleteCue method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.InsertCue 100, 40, "Label1", "Note1", "Text1", "Language1", "Country1", "Dialect1", 1
Info.cueNum = Info.cueCount
Info.cueCodePage = 2
Info.cueCountry = "Country2"
Info.cueDialect = "Dialect2"
Info.cueLabel = "Label2"
Info.cueLanguage = "Language2"
Info.cueLength = 44
Info.cueNote = "Note2"
Info.cuePosition = 144
Info.cueText = "Text2"

See Also:

InsertCue | cueCodePage | cueCount | cueCountry | cueDialect | cueLabel | cueLanguage | cueLength | cueNote | cueNum | cueText | DeleteCue


cueText property (AudioInformation2)

cueText property (AudioInformation2)

Gets or sets text field for the current cue point in the audio file.

Property type

A String value.

Syntax

object.cueText [= value]

The cueText property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | String | The text field for the current cue point in the audio file.

Remarks:

The text is a null terminated string of characters. If the number of characters in the string is not even, padding must be appended to the string. The appended padding is not considered in the label chunk's chunk size field.

You can insert a cue point in the cue list in the audio file by the InsertCue method and delete by the DeleteCue method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.InsertCue 100, 40, "Label1", "Note1", "Text1", "Language1", "Country1", "Dialect1", 1
Info.cueNum = Info.cueCount
Info.cueCodePage = 2
Info.cueCountry = "Country2"
Info.cueDialect = "Dialect2"
Info.cueLabel = "Label2"
Info.cueLanguage = "Language2"
Info.cueLength = 44
Info.cueNote = "Note2"
Info.cuePosition = 144
Info.cueText = "Text2"

See Also:

InsertCue | cueCodePage | cueCount | cueCountry | cueDialect | cueLabel | cueLanguage | cueLength | cueNote | cueNum | cuePosition | DeleteCue


Duration property (AudioInformation2)

Duration property (AudioInformation2)

Read-only property that returns the duration of the audio file.

Property type

A Long value.

Syntax

value = object.Duration

The Duration property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Long | The duration of the audio file in milliseconds.

Example:

' VB sample where Info is an AudioInformation2 object.
infoFormatString.Text = Info.FormatString
infoFrequency.Text = Info.Frequency & " Hz"
infoBitrate.Text = Info.Bitrate & " bps"
infoDuration.Text = Info.Duration & " ms"
infoChannels.Text = Info.Channels
infoSamples.Text = Info.Samples
infoSize.Text = Info.Size
infoBitsPerSample.Text = Info.BitsPerSample
infoFormatTag.Text = Info.FormatTag

See Also:

Bitrate | BitsPerSample | Channels | FormatString | FormatTag | Frequency | Samples | Size | Type


FormatString property (AudioInformation2)

FormatString property (AudioInformation2)

Read-only property that returns the string with information about the audio file format.

Property type

A String value.

Syntax

value = object.FormatString

The FormatString property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | String | The string with information about the audio file format.

Example:

' VB sample where Info is an AudioInformation2 object.
infoFormatString.Text = Info.FormatString
infoFrequency.Text = Info.Frequency & " Hz"
infoBitrate.Text = Info.Bitrate & " bps"
infoDuration.Text = Info.Duration & " ms"
infoChannels.Text = Info.Channels
infoSamples.Text = Info.Samples
infoSize.Text = Info.Size
infoBitsPerSample.Text = Info.BitsPerSample
infoFormatTag.Text = Info.FormatTag

See Also:

Bitrate | BitsPerSample | Channels | Duration | FormatTag | Frequency | Samples | Size | Type


FormatTag property (AudioInformation2)

FormatTag property (AudioInformation2)

Read-only property that returns the waveform-audio format type of a WAV file.

Property type

A Long value.

Syntax

value = object.FormatTag

The FormatTag property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object of type .
value | Long | The waveform-audio format type of a WAV file.

Remarks:

Format tags are registered with the Microsoft Corporation for many compression algorithms.

Example:

' VB sample where Info is an AudioInformation2 object.
infoFormatString.Text = Info.FormatString
infoFrequency.Text = Info.Frequency & " Hz"
infoBitrate.Text = Info.Bitrate & " bps"
infoDuration.Text = Info.Duration & " ms"
infoChannels.Text = Info.Channels
infoSamples.Text = Info.Samples
infoSize.Text = Info.Size
infoBitsPerSample.Text = Info.BitsPerSample
infoFormatTag.Text = Info.FormatTag

See Also:

Bitrate | BitsPerSample | Channels | Duration | FormatString | Frequency | Samples | Size | Type


Frequency property (AudioInformation2)

Frequency property (AudioInformation2)

Read-only property that returns the frequency for the audio file.

Property type

A Long value.

Syntax

value = object.Frequency

The Frequency property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Long | The frequency in Hz of the audio file.

Example:

' VB sample where Info is an AudioInformation2 object.
infoFormatString.Text = Info.FormatString
infoFrequency.Text = Info.Frequency & " Hz"
infoBitrate.Text = Info.Bitrate & " bps"
infoDuration.Text = Info.Duration & " ms"
infoChannels.Text = Info.Channels
infoSamples.Text = Info.Samples
infoSize.Text = Info.Size
infoBitsPerSample.Text = Info.BitsPerSample
infoFormatTag.Text = Info.FormatTag

See Also:

Bitrate | BitsPerSample | Channels | Duration | FormatString | FormatTag | Samples | Size | Type


infoAlbum property (AudioInformation2)

infoAlbum property (AudioInformation2)

Gets or sets the string with the album name, which contains the audio file subject.

Property type

A String value.

Syntax

object.infoAlbum [= value]

The infoAlbum property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | String | The album name.

Remarks:

infoAlbum property accepts correct value only after applying of the GetAudioInformation method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.infoAlbum = "Unknown album"
Info.infoArtist = "Unknown artist"
Info.infoComments = "No comments"
Info.infoComposer = "Unknown composer"
Info.infoCopyright = ""
Info.infoEncodedBy = ""
Info.infoGenreS = "Pop"
Info.infoOriginalArtist = "Unknown original artist"
Info.infoTitle = "No title"
Info.infoTrack = "test"
Info.infoURL = "http://www.nctsoft.com"
Info.infoYear = "2003"
Info.SetAudioInformation "c:\music.wav"

See Also:

GetAudioInformation | infoArtist | infoComments | infoComposer | infoCopyright | infoEncodedBy | infoGenre | infoGenreS | infoOriginalArtist | infoTitle | infoTrack | infoURL | infoYear | SetAudioInformation


infoArtist property (AudioInformation2)

infoArtist property (AudioInformation2)

Gets or sets the string with the name of the artist who created the original subject of the file. If there are many artists, the names are separated by a semicolon and a blank.

Property type

A String value.

Syntax

object.infoArtist [= value]

The infoArtist property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | String | Artist's name.

Remarks:

infoArtist property accepts correct value only after applying of the GetAudioInformation method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.infoAlbum = "Unknown album"
Info.infoArtist = "Unknown artist"
Info.infoComments = "No comments"
Info.infoComposer = "Unknown composer"
Info.infoCopyright = ""
Info.infoEncodedBy = ""
Info.infoGenreS = "Pop"
Info.infoOriginalArtist = "Unknown original artist"
Info.infoTitle = "No title"
Info.infoTrack = "test"
Info.infoURL = "http://www.nctsoft.com"
Info.infoYear = "2003"
Info.SetAudioInformation "c:\music.wav"

See Also:

GetAudioInformation | infoAlbum | infoComments | infoComposer | infoCopyright | infoEncodedBy | infoGenre | infoGenreS | infoOriginalArtist | infoTitle | infoTrack | infoURL | infoYear | SetAudioInformation


infoComments property (AudioInformation2)

infoComments property (AudioInformation2)

Gets or sets the string with general comments about the audio file or the audio file subject.

Property type

A String value.

Syntax

object.infoComments [= value]

The infoComments property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | String | The string with general comments.

Remarks:

infoComments property accepts correct value only after applying of the GetAudioInformation method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.infoAlbum = "Unknown album"
Info.infoArtist = "Unknown artist"
Info.infoComments = "No comments"
Info.infoComposer = "Unknown composer"
Info.infoCopyright = ""
Info.infoEncodedBy = ""
Info.infoGenreS = "Pop"
Info.infoOriginalArtist = "Unknown original artist"
Info.infoTitle = "No title"
Info.infoTrack = "test"
Info.infoURL = "http://www.nctsoft.com"
Info.infoYear = "2003"
Info.SetAudioInformation "c:\music.wav"

See Also:

GetAudioInformation | infoAlbum | infoArtist | infoComposer | infoCopyright | infoEncodedBy | infoGenre | infoGenreS | infoOriginalArtist | infoTitle | infoTrack | infoURL | infoYear | SetAudioInformation


infoComposer property (AudioInformation2)

infoComposer property (AudioInformation2)

Gets or sets the string with the name of the composer who created the original music of the file.

Property type

A String value.

Syntax

object.infoComposer [= value]

The infoComposer property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | String | Composer's name.

Remarks:

infoComposer property accepts correct value only after applying of the GetAudioInformation method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.infoAlbum = "Unknown album"
Info.infoArtist = "Unknown artist"
Info.infoComments = "No comments"
Info.infoComposer = "Unknown composer"
Info.infoCopyright = ""
Info.infoEncodedBy = ""
Info.infoGenreS = "Pop"
Info.infoOriginalArtist = "Unknown original artist"
Info.infoTitle = "No title"
Info.infoTrack = "test"
Info.infoURL = "http://www.nctsoft.com"
Info.infoYear = "2003"
Info.SetAudioInformation "c:\music.wav"

See Also:

GetAudioInformation | infoAlbum | infoArtist | infoComments | infoCopyright | infoEncodedBy | infoGenre | infoGenreS | infoOriginalArtist | infoTitle | infoTrack | infoURL | infoYear | SetAudioInformation


infoCopyright property (AudioInformation2)

infoCopyright property (AudioInformation2)

Gets or sets the string with the copyright information of the audio file.

Property type

A String value.

Syntax

object.infoCopyright [= value]

The infoCopyright property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | String | The copyright information.

Remarks:

infoCopyright property accepts correct value only after applying of the GetAudioInformation method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.infoAlbum = "Unknown album"
Info.infoArtist = "Unknown artist"
Info.infoComments = "No comments"
Info.infoComposer = "Unknown composer"
Info.infoCopyright = ""
Info.infoEncodedBy = ""
Info.infoGenreS = "Pop"
Info.infoOriginalArtist = "Unknown original artist"
Info.infoTitle = "No title"
Info.infoTrack = "test"
Info.infoURL = "http://www.nctsoft.com"
Info.infoYear = "2003"
Info.SetAudioInformation "c:\music.wav"

See Also:

GetAudioInformation | infoAlbum | infoArtist | infoComments | infoComposer | infoEncodedBy | infoGenre | infoGenreS | infoOriginalArtist | infoTitle | infoTrack | infoURL | infoYear | SetAudioInformation


infoEncodedBy property (AudioInformation2)

infoEncodedBy property (AudioInformation2)

Gets or sets the string with information about the encoder.

Property type

A String value.

Syntax

object.infoEncodedBy [= value]

The infoEncodedBy property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | String | Type of encoder.

Remarks:

infoEncodedBy property accepts correct value only after applying of the GetAudioInformation method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.infoAlbum = "Unknown album"
Info.infoArtist = "Unknown artist"
Info.infoComments = "No comments"
Info.infoComposer = "Unknown composer"
Info.infoCopyright = ""
Info.infoEncodedBy = ""
Info.infoGenreS = "Pop"
Info.infoOriginalArtist = "Unknown original artist"
Info.infoTitle = "No title"
Info.infoTrack = "test"
Info.infoURL = "http://www.nctsoft.com"
Info.infoYear = "2003"
Info.SetAudioInformation "c:\music.wav"

See Also:

GetAudioInformation | infoAlbum | infoArtist | infoComments | infoComposer | infoCopyright | infoGenre | infoGenreS | infoOriginalArtist | infoTitle | infoTrack | infoURL | infoYear | SetAudioInformation


infoGenre property (AudioInformation2)

infoGenre property (AudioInformation2 object)

Gets or sets the genre number or classification string number of the audio file.

Property type

An Integer value.

Syntax

object.infoGenre [= value]

The infoGenre property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Integer | The genre number.

Remarks:

infoGenre property accepts correct value only after applying of the GetAudioInformation method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.infoAlbum = "Unknown album"
Info.infoArtist = "Unknown artist"
Info.infoComments = "No comments"
Info.infoComposer = "Unknown composer"
Info.infoCopyright = ""
Info.infoEncodedBy = ""
Info.infoGenreS = "Pop"
Info.infoOriginalArtist = "Unknown original artist"
Info.infoTitle = "No title"
Info.infoTrack = "test"
Info.infoURL = "http://www.nctsoft.com"
Info.infoYear = "2003"
Info.SetAudioInformation "c:\music.wav"

See Also:

GetAudioInformation | infoAlbum | infoArtist | infoComments | infoComposer | infoCopyright | infoEncodedBy | infoGenreS | infoOriginalArtist | infoTitle | infoTrack | infoURL | infoYear | SetAudioInformation

Applies to: AudioInformation2

Send Feedback on the NCTAudioInformation2 documentation.
NCTAudioInformation2 was developed by NCT company http://www.nctsoft.com


infoGenreS property (AudioInformation2)

infoGenreS property (AudioInformation2)

Gets or sets the genre or classification string of the audio file.

Property type

An Integer value.

Syntax

object.infoGenreS [= value]

The infoGenreS property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | String | The genre or classification of the audio file.

Remarks:

infoGenreS property accepts correct value only after applying of the GetAudioInformation method.

The list of genres is in the Genre string.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.infoAlbum = "Unknown album"
Info.infoArtist = "Unknown artist"
Info.infoComments = "No comments"
Info.infoComposer = "Unknown composer"
Info.infoCopyright = ""
Info.infoEncodedBy = ""
Info.infoGenreS = "Pop"
Info.infoOriginalArtist = "Unknown original artist"
Info.infoTitle = "No title"
Info.infoTrack = "test"
Info.infoURL = "http://www.nctsoft.com"
Info.infoYear = "2003"
Info.SetAudioInformation "c:\music.wav"

See Also:

GetAudioInformation | infoAlbum | infoArtist | infoComments | infoComposer | infoCopyright | infoEncodedBy | infoGenre | infoOriginalArtist | infoTitle | infoTrack | infoURL | infoYear | SetAudioInformation


infoOriginalArtist property (AudioInformation2)

infoOriginalArtist property (AudioInformation2 object)

Gets or sets the string with the name of the artist who created the original subject of the file. If there are many artists, the names are separated by a semicolon and a blank.

Property type

A String value.

Syntax

object.infoOriginalArtist [= value]

The infoOriginalArtist property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | String | Artist's name.

Remarks:

infoOriginalArtist property accepts correct value only after applying of the GetAudioInformation method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.infoAlbum = "Unknown album"
Info.infoArtist = "Unknown artist"
Info.infoComments = "No comments"
Info.infoComposer = "Unknown composer"
Info.infoCopyright = ""
Info.infoEncodedBy = ""
Info.infoGenreS = "Pop"
Info.infoOriginalArtist = "Unknown original artist"
Info.infoTitle = "No title"
Info.infoTrack = "test"
Info.infoURL = "http://www.nctsoft.com"
Info.infoYear = "2003"
Info.SetAudioInformation "c:\music.wav"

See Also:

GetAudioInformation | infoAlbum | infoArtist | infoComments | infoComposer | infoCopyright | infoEncodedBy | infoGenre | infoGenreS | infoTitle | infoTrack | infoURL | infoYear | SetAudioInformation

Applies to: AudioInformation2

Send Feedback on the NCTAudioInformation2 documentation.
NCTAudioInformation2 was developed by NCT company http://www.nctsoft.com


infoTitle property (AudioInformation2)

infoTitle property (AudioInformation2)

Gets or sets the string with the title of the audio file's subject.

Property type

A String value.

Syntax

object.infoTitle [= value]

The infoTitle property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | String | The file's title.

Remarks:

infoTitle property accepts correct value only after applying of the GetAudioInformation method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.infoAlbum = "Unknown album"
Info.infoArtist = "Unknown artist"
Info.infoComments = "No comments"
Info.infoComposer = "Unknown composer"
Info.infoCopyright = ""
Info.infoEncodedBy = ""
Info.infoGenreS = "Pop"
Info.infoOriginalArtist = "Unknown original artist"
Info.infoTitle = "No title"
Info.infoTrack = "test"
Info.infoURL = "http://www.nctsoft.com"
Info.infoYear = "2003"
Info.SetAudioInformation "c:\music.wav"

See Also:

GetAudioInformation | infoAlbum | infoArtist | infoComments | infoComposer | infoCopyright | infoEncodedBy | infoGenre | infoGenreS | infoOriginalArtist | infoTrack | infoURL | infoYear | SetAudioInformation


infoTrack property (AudioInformation2)

infoTrack property (AudioInformation2)

Gets or sets the number of track of the audio file's subject.

Property type

An Integer value.

Syntax

object.infoTrack [= value]

The infoTrack property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Integer | Number of track.

Remarks:

infoTrack property accepts correct value only after applying of the GetAudioInformation method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.infoAlbum = "Unknown album"
Info.infoArtist = "Unknown artist"
Info.infoComments = "No comments"
Info.infoComposer = "Unknown composer"
Info.infoCopyright = ""
Info.infoEncodedBy = ""
Info.infoGenreS = "Pop"
Info.infoOriginalArtist = "Unknown original artist"
Info.infoTitle = "No title"
Info.infoTrack = "test"
Info.infoURL = "http://www.nctsoft.com"
Info.infoYear = "2003"
Info.SetAudioInformation "c:\music.wav"

See Also:

GetAudioInformation | infoAlbum | infoArtist | infoComments | infoComposer | infoCopyright | infoEncodedBy | infoGenre | infoGenreS | infoOriginalArtist | infoTitle | infoURL | infoYear | SetAudioInformation


infoURL property (AudioInformation2)

infoURL property (AudioInformation2)

Gets or sets the URL of the audio file's subject.

Property type

A String value.

Syntax

object.infoURL [= value]

The infoURL property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | String | The URL of the audio file's subject.

Remarks:

infoURL property accepts correct meaning only after applying of the GetAudioInformation method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.infoAlbum = "Unknown album"
Info.infoArtist = "Unknown artist"
Info.infoComments = "No comments"
Info.infoComposer = "Unknown composer"
Info.infoCopyright = ""
Info.infoEncodedBy = ""
Info.infoGenreS = "Pop"
Info.infoOriginalArtist = "Unknown original artist"
Info.infoTitle = "No title"
Info.infoTrack = "test"
Info.infoURL = "http://www.nctsoft.com"
Info.infoYear = "2003"
Info.SetAudioInformation "c:\music.wav"

See Also:

GetAudioInformation | infoAlbum | infoArtist | infoComments | infoComposer | infoCopyright | infoEncodedBy | infoGenre | infoGenreS | infoOriginalArtist | infoTitle | infoTrack | infoYear | SetAudioInformation


infoYear property (AudioInformation2)

infoYear property (AudioInformation2)

Gets or sets the year when the audio file subject was created.

Property type

A Long value.

Syntax

object.infoYear [= value]

The infoYear property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Long | The year when the audio file subject was created.

Remarks:

infoYear property accepts correct meaning only after applying of the GetAudioInformation method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.infoAlbum = "Unknown album"
Info.infoArtist = "Unknown artist"
Info.infoComments = "No comments"
Info.infoComposer = "Unknown composer"
Info.infoCopyright = ""
Info.infoEncodedBy = ""
Info.infoGenreS = "Pop"
Info.infoOriginalArtist = "Unknown original artist"
Info.infoTitle = "No title"
Info.infoTrack = "test"
Info.infoURL = "http://www.nctsoft.com"
Info.infoYear = "2003"
Info.SetAudioInformation "c:\music.wav"

See Also:

GetAudioInformation | infoAlbum | infoArtist | infoComments | infoComposer | infoCopyright | infoEncodedBy | infoGenre | infoGenreS | infoOriginalArtist | infoTitle | infoTrack | infoURL | SetAudioInformation


mp3FastAnalysis property (AudioInformation2)

mp3FastAnalysis property (AudioInformation2)

Gets or sets a flag indicating if fast MP3 analysis is enabled or not.

Property type

A Boolean value.

Syntax

object.mp3FastAnalysis [= value]

The mp3FastAnalysis property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Boolean | True if fast analysis of an MP3 file is performed, otherwise - False.

Remarks:

It is for compatibility with previous versions of NCTAudioInformation2.

See Also:


mp3TagInfoVersion property (AudioInformation2)

mp3TagInfoVersion property (AudioInformation2)

Gets or sets the version of an MP3 audio file.

Property type

An Integer value.

Syntax

object.mp3TagInfoVersion [= value]

The mp3TagInfoVersion property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Integer | Can be one of the following values: 1 - first version, 2 - second version.

Remarks:

There are two mp3 tag versions: ID3 version 1 and ID3 version 2. The first version have only 7 parameters: track number (infoTrack property), title (infoTitle property), artist (infoArtist property), album (infoAlbum property), year (infoYear property), genre (infoGenre property), comments (infoComments property). The maximal size of the comments string is equal to 30 symbols. Other symbols will be cut. The cutting of the comments string is conditioned by the requirements of the first tag version.

The second version have all the infoXXX parameters with the exception of the infoGenre property. There is not the ready-made list of the genres for this tag version. You can set genre using the infoGenreS property. This version do not have a limitation of the comments string size.


Samples property (AudioInformation2)

Samples property (AudioInformation2)

Read-only property that returns the number of samples in an audio file.

Property type

A Long value.

Syntax

value = object.Samples

The Samples property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Long | The number of samples in an audio file.

Example:

' VB sample where Info is an AudioInformation2 object.
infoFormatString.Text = Info.FormatString
infoFrequency.Text = Info.Frequency & " Hz"
infoBitrate.Text = Info.Bitrate & " bps"
infoDuration.Text = Info.Duration & " ms"
infoChannels.Text = Info.Channels
infoSamples.Text = Info.Samples
infoSize.Text = Info.Size
infoBitsPerSample.Text = Info.BitsPerSample
infoFormatTag.Text = Info.FormatTag

See Also:

Bitrate | BitsPerSample | Channels | Duration | FormatString | FormatTag | Frequency | Size | Type


Size property (AudioInformation2)

Size property (AudioInformation2)

Read-only property that returns the size of an audio file.

Property type

A Long value.

Syntax

value = object.Size

The Size property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Long | The size is in bytes.

Example:

' VB sample where Info is an AudioInformation2 object.
infoFormatString.Text = Info.FormatString
infoFrequency.Text = Info.Frequency & " Hz"
infoBitrate.Text = Info.Bitrate & " bps"
infoDuration.Text = Info.Duration & " ms"
infoChannels.Text = Info.Channels
infoSamples.Text = Info.Samples
infoSize.Text = Info.Size
infoBitsPerSample.Text = Info.BitsPerSample
infoFormatTag.Text = Info.FormatTag

See Also:

Bitrate | BitsPerSample | Channels | Duration | FormatString | FormatTag | Frequency | Samples | Type


Type property (AudioInformation2)

Type property (AudioInformation2)

Read-only property that returns the type of an audio file.

Property type

An Integer value.

Syntax

value = object.Type

The Type property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Integer | 1 if audio file has a WAV type, 2, if audio file has a MPEG type, 3, if audio file has a Ogg Vorbis type, 4, if audio file has a MP+ type and 5 if audio file has a AVI type.

Example:

' VB sample where Info is an AudioInformation2 object.
infoType = "Unknown file"
If Info.Type = 1 Then infoType = "WAV file"
If Info.Type = 2 Then infoType = "MPEG file"
If Info.Type = 3 Then infoType = "Ogg Vorbis file"
If Info.Type = 4 Then infoType = "MP+ file"
If Info.Type = 5 Then infoType = "AVI file"

See Also:

Bitrate | BitsPerSample | Channels | Duration | FormatString | FormatTag | Frequency | Samples | Size


WmaFormatEnabled property (AudioInformation2)

WmaFormatEnabled property (AudioInformation2 object)

Gets or sets a flag indicating if WMA format is enabled or not.

Property type

A Boolean value.

Syntax

object.WmaFormatEnabled [= value]

The WmaFormatEnabled property syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
value | Boolean | Can be True (WMA format is enabled) or False (WMA format is disabled).

See Also:

Applies to: AudioInformation2

Send Feedback on the NCTAudioInformation2 documentation.
NCTAudioInformation2 was developed by NCT company http://www.nctsoft.com


AudioInformation2 methods

AudioInformation2 methods

Method | Description
DeleteCue | Deletes the current cue point from the cue list in the audio file.
GenreToString | Converts genre code to the genre string.
GetAudioInformation | Gets information about an audio file.
InsertCue | Inserts a cue point in the cue list in the audio file.
IsAudioFile | Gets information about the file type.
IsAviFile | Gets information about the file type.
IsInfoSupported | Gets information about the file type.
IsMp2File | Gets information about the file type.
IsMp3File | Gets information about the file type.
IsMPCFile | Gets information about the file type.
IsOggVorbisFile | Gets information about the file type.
IsWavFile | Gets information about the file type.
IsWMAFile | Gets information about the file type.
Register | Enters user name and registration password to disable About window.
SetAudioInformation | Writes information tags to an audio file.


DeleteCue method

DeleteCue method

Deletes the current cue point from the cue list in the audio file.

Syntax

object.DeleteCue

The DeleteCue method syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.

Remarks:

The current cue point set by cueNum property. You can insert a cue point in the cue list in the audio file by the InsertCue method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.InsertCue 100, 40, "Label1", "Note1", "Text1", "Language1", "Country1", "Dialect1", 1
Info.InsertCue 100, 40, "Label2", "Note2", "Text2", "Language2", "Country2", "Dialect2", 1
Info.InsertCue 100, 40, "Label3", "Note3", "Text3", "Language3", "Country3", "Dialect3", 1
Info.InsertCue 100, 40, "Label4", "Note4", "Text4", "Language4", "Country4", "Dialect4", 1
Info.cueNum = Info.cueCount - 2
Info.DeleteCue

See Also:

InsertCue | cueCodePage | cueCount | cueCountry | cueDialect | cueLabel | cueLanguage | cueLength | cueNote | cueNum | cuePosition | cueText


GenreToString method

GenreToString method

Converts genre code to the genre string.

Return Type

A String value.

Syntax

sGenre = object.GenreToString(nGenre As Integer)

The GenreToString method syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
nGenre | Integer | Genre code.
sGenre | String | Genre string.

Remarks:

To get genre code you should use the infoGenre property.

The list of genres is in the Genre string.


GetAudioInformation method

GetAudioInformation method

Gets information about an audio file.

Syntax

object.GetAudioInformation(fileName As String)

The GetAudioInformation method syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
fileName | String | The audio file pathname.

Remarks:

You can get and set the following properties after applying the GetAudioInformation method: infoAlbum, infoArtist, infoComments, infoComposer, infoCopyright, infoEncodedBy, infoGenreS, infoOriginalArtist, infoTitle, infoTrack, infoURL, infoYear.

The following list shows information types that can be written to the audio file for each supported audio file format:

property | ID3v1 MP2, MP3 | ID3v2 MP2, MP3 | MP+ | OGG | WAV
infoAlbum | + | + | + | + | +
infoArtist | + | + | + | + | +
infoComments | + | + | + | + | +
infoComposer | - | + | - | + | +
infoCopyright | - | + | - | + | +
infoEncodedBy | - | + | - | + | +
infoGenreS | + | + | + | + | +
infoOriginalArtist | - | + | - | + | +
infoTitle | + | + | + | + | +
infoTrack | + | + | + | + | +
infoURL | - | + | - | + | +
infoYear | + | + | + | + | +

Example:

' VB sample where Info is an AudioInformation2 object.
Info.GetAudioInformation "c:\music01.wav"
Info.infoYear = "2003"
Info.SetAudioInformation "c:\music02.wav"

See Also:

infoAlbum | infoArtist | infoComments | infoComposer | infoCopyright | infoEncodedBy | infoGenre | infoGenreS | infoOriginalArtist | infoTitle | infoTrack | infoURL | infoYear | SetAudioInformation


InsertCue method

InsertCue method

Inserts a cue point in the cue list in the audio file.

Syntax

object.InsertCue(Position As Long, Length As Long, Label As String, Note As String, Text As String, Language As Integer, Country As Integer, Dialect As Integer, CodePage As Integer)

The InsertCue method syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
Position | Long | The position of the current cue point in the cue list. The cuePosition property gets or sets this value.
Length | Long | The length of the current cue point in the cue list. The cueLength property gets or sets this value.
Label | String | Label field of the current cue point. The cueLabel property gets or sets this value.
Note | String | Note field in the current cue point in the audio file. The cueNote property gets or sets this value.
Text | String | Text field for the current cue point. The cueText property gets or sets this value.
Language | Integer | Language code for the cue list. The cueLanguage property gets or sets this value.
Country | Integer | The country code for the cue list. The cueCountry property gets or sets this value.
Dialect | Integer | The dialect for the cue list. The cueDialect property gets or sets this value.
CodePage | Integer | The code page for the cue list. The cueCodePage property gets or sets this value.

Remarks:

You can delete the current cue point from the cue list in the audio file by the DeleteCue method.

Example:

' VB sample where Info is an AudioInformation2 object.
Info.InsertCue 100, 40, "Label1", "Note1", "Text1", "Language1", "Country1", "Dialect1", 1
Info.cueNum = Info.cueCount
Info.cueCodePage = 2
Info.cueCountry = "Country2"
Info.cueDialect = "Dialect2"
Info.cueLabel = "Label2"
Info.cueLanguage = "Language2"
Info.cueLength = 44
Info.cueNote = "Note2"
Info.cuePosition = 144
Info.cueText = "Text2"

See Also:

cueCodePage | cueCount | cueCountry | cueDialect | cueLabel | cueLanguage | cueLength | cueNote | cueNum | cuePosition | cueText | DeleteCue


IsAudioFile method

IsAudioFile method

Gets information about the file type.

Return Type

A Boolean value.

Syntax

IsAudioFile = object.IsAudioFile(fileName As String)

The IsAudioFile method syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
fileName | String | File's pathname.
IsAudioFile | Boolean | True if file has the audio type, otherwise - False.

See Also:

IsAviFile method | IsInfoSupported method | IsMp2File method | IsMp3File method | IsMPCFile method | IsOggVorbisFile method | IsWavFile method | IsWMAFile method


IsAviFile method

IsAviFile method

Gets information about the audio file type.

Return Type

A Boolean value.

Syntax

IsAviFile = object.IsAviFile(fileName As String)

The IsAviFile method syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
fileName | String | Audio file's pathname.
IsAviFile | Boolean | Type of an audio file. True if Audio file has the AVI type, otherwise - False.

See Also:

IsAudioFile method | IsInfoSupported method | IsMp2File method | IsMp3File method | IsMPCFile method | IsOggVorbisFile method | IsWavFile method | IsWMAFile method


IsInfoSupported method

IsInfoSupported method

Gets information about the audio file type.

Return Type

A Boolean value.

Syntax

IsInfoSupported = object.IsInfoSupported(fileName As String)

The IsInfoSupported method syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
fileName | String | Audio file's pathname.
IsInfoSupported | Boolean | True if audio file supports record of information, otherwise - False.

See Also:

IsAudioFile method | IsAviFile method | IsMp2File method | IsMp3File method | IsMPCFile method | IsOggVorbisFile method | IsWavFile method | IsWMAFile method


IsMp2File method

IsMp2File method

Gets information about the audio file type.

Return Type

A Boolean value.

Syntax

object.IsMp2File(fileName As String)

The IsMp2File method syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
fileName | String | Audio file's pathname.
IsMp3 | Boolean | Type of an audio file. True if Audio file has the MP2 type, otherwise - False.

See Also:

IsAudioFile method | IsAviFile method | IsInfoSupported method | IsMp3File method | IsMPCFile method | IsOggVorbisFile method | IsWavFile method | IsWMAFile method


IsMp3File method

IsMp3File method

Gets information about the audio file type.

Return Type

A Boolean value.

Syntax

IsMp3 = object.IsMp3File(fileName As String)

The IsMp3File method syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
fileName | String | Audio file's pathname.
IsMp3 | Boolean | Type of an audio file. True if Audio file has the MP3 type, otherwise - False.

See Also:

IsAudioFile method | IsAviFile method | IsInfoSupported method | IsMp2File method | IsMPCFile method | IsOggVorbisFile method | IsWavFile method | IsWMAFile method


IsMPCFile method

IsMPCFile method (AudioInformation2 object)

Gets information about the audio file type.

Return Type

A Boolean value.

Syntax

object.IsMPCFile(fileName As String)

The IsMPCFile method syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
fileName | String | Type of an audio file. True if Audio file has the MPC type, otherwise - False.

Remarks:

Example:

See Also:

IsAudioFile method | IsAviFile method | IsInfoSupported method | IsMp2File method | IsMp3File method | IsOggVorbisFile method | IsWavFile method | IsWMAFile method

Applies to: AudioInformation2

Send Feedback on the NCTAudioInformation2 documentation.
NCTAudioInformation2 was developed by NCT company http://www.nctsoft.com


IsOggVorbisFile method

IsOggVorbisFile method

Gets information about the audio file type.

Return Type

A Boolean value.

Syntax

IsOggVorbis = object.IsOggVorbisFile(fileName As String)

The IsOggVorbisFile method syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
fileName | String | Audio file's pathname.
IsOggVorbis | Boolean | Type of an audio file. True if Audio file has the Ogg Vorbis type, otherwise - False.

See Also:

IsAudioFile method | IsAviFile method | IsInfoSupported method | IsMp2File method | IsMp3File method | IsMPCFile method | IsWavFile method | IsWMAFile method


IsWavFile method

IsWavFile method

Gets information about the audio file type.

Return Type

A Boolean value.

Syntax

IsWav =object.IsWavFile(fileName As String)

The IsWavFile method syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object of type .
fileName | String | Audio file's pathname.
IsWav | Boolean | Type of an audio file. True if Audio file has the WAV type, otherwise - False.

See Also:

IsAudioFile method | IsAviFile method | IsInfoSupported method | IsMp2File method | IsMp3File method | IsMPCFile method | IsOggVorbisFile method | IsWMAFile method


IsWMAFile method

IsWMAFile method (AudioInformation2 object)

Gets information about the audio file type.

Return Type

A Boolean value.

Syntax

object.IsWMAFile(fileName As String)

The IsWMAFile method syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
fileName | String | Type of an audio file. True if Audio file has the WMA type, otherwise - False.

Remarks:

Example:

See Also:

IsAudioFile method | IsAviFile method | IsInfoSupported method | IsMp2File method | IsMp3File method | IsMPCFile method | IsOggVorbisFile method | IsWavFile method

Applies to: AudioInformation2

Send Feedback on the NCTAudioInformation2 documentation.
NCTAudioInformation2 was developed by NCT company http://www.nctsoft.com


Register method

Register method

Enters user name and registration password to disable About window.

Syntax

object.Register(bstrUser As String, bstrPassword As String)

The Register method syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object of type .
bstrUser | String | User name. You get a registration user name after the registration.
bstrPassword | String | Password string. You get a registration password after the registration.


SetAudioInformation method

SetAudioInformation method

Writes information tags to an audio file.

Return Type

A Boolean value.

Syntax

object.SetAudioInformation(fileName As String)

The SetAudioInformation method syntax has these parts:

Part | Type | Description
object | AudioInformation2 | An expression evaluating to an object.
fileName | String | Audio file's pathname.

Remarks:

Writes values of the following properties to an audio file: infoAlbum, infoArtist, infoComments, infoComposer, infoCopyright, infoEncodedBy, infoGenreS, infoOriginalArtist, infoTitle, infoTrack, infoURL, infoYear.

The following list shows information types that can be written to the audio file for each supported audio file format:

property | ID3v1 MP2, MP3 | ID3v2 MP2, MP3 | MP+ | OGG | WAV
infoAlbum | + | + | + | + | +
infoArtist | + | + | + | + | +
infoComments | + | + | + | + | +
infoComposer | - | + | - | + | +
infoCopyright | - | + | - | + | +
infoEncodedBy | - | + | - | + | +
infoGenreS | + | + | + | + | +
infoOriginalArtist | - | + | - | + | +
infoTitle | + | + | + | + | +
infoTrack | + | + | + | + | +
infoURL | - | + | - | + | +
infoYear | + | + | + | + | +

Example:

' VB sample where Info is an AudioInformation2 object.
Info.infoAlbum = "Unknown album"
Info.infoArtist = "Unknown artist"
Info.infoComments = "No comments"
Info.infoComposer = "Unknown composer"
Info.infoCopyright = ""
Info.infoEncodedBy = ""
Info.infoGenreS = "Pop"
Info.infoOriginalArtist = "Unknown original artist"
Info.infoTitle = "No title"
Info.infoTrack = "test"
Info.infoURL = "http://www.nctsoft.com"
Info.infoYear = "2003"
Info.SetAudioInformation "c:\music.wav"

See Also:

GetAudioInformation | infoAlbum | infoArtist | infoComments | infoComposer | infoCopyright | infoEncodedBy | infoGenre | infoGenreS | infoOriginalArtist | infoTitle | infoTrack | infoURL | infoYear


Genre

Audio file genres

Value | Description
00 | Blues
01 | Classic Rock
02 | Country
03 | Dance
04 | Disco
05 | Funk
06 | Grunge
07 | Hip-Hop
08 | Jazz
09 | Metal
10 | New Age
11 | Oldies
12 | Other
13 | Pop
14 | R&B
15 | Rap
16 | Reggae
17 | Rock
18 | Techno
19 | Industrial
20 | Alternative
21 | Ska
22 | Death Metal
23 | Pranks
24 | Soundtrack
25 | Euro-Techno
26 | Ambient
27 | Trip-Hop
28 | Vocal
29 | Jazz+Funk
30 | Fusion
31 | Trance
32 | Classical
33 | Instrumental
34 | Acid
35 | House
36 | Game
37 | Sound Clip
38 | Gospel
39 | Noise
40 | Alternative Rock
41 | Bass
42 | Soul
43 | Punk
44 | Space
45 | Meditative
46 | Instrumental Pop
47 | Instrumental Rock
48 | Ethnic
49 | Gothic
50 | Darkwave
51 | Techno-Industrial
52 | Electronic
53 | Pop-Folk
54 | Eurodance
55 | Dream
56 | Southern Rock
57 | Comedy
58 | Cult
59 | Gangsta
60 | Top 40
61 | Christian Rap
62 | Pop/Funk
63 | Jungle
64 | Native US
65 | Cabaret
66 | New Wave
67 | Psychedelic
68 | Rave
69 | Showtunes
70 | Trailer
71 | Lo-Fi
72 | Tribal
73 | Acid Punk
74 | Acid Jazz
75 | Polka
76 | Retro
77 | Musical
78 | Rock & Roll
79 | Hard Rock
80 | Folk
81 | Folk-Rock
82 | National Folk
83 | Swing
84 | Fast Fusion
85 | Bebop
86 | Latin
87 | Revival
88 | Celtic
89 | Bluegrass
90 | Avant-garde
91 | Gothic Rock
92 | Progressive Rock
93 | Psychedelic Rock
94 | Symphonic Rock
95 | Slow Rock
96 | Big Band
97 | Chorus
98 | Easy Listening
99 | Acoustic
100 | Humor
101 | Speech
102 | Chanson
103 | Opera
104 | Chamber Music
105 | Sonata
106 | Symphony
107 | Booty Bass
108 | Primus
109 | Porn Groove
110 | Satire
111 | Slow Jam
112 | Club
113 | Tango
114 | Samba
115 | Folklore
116 | Ballad
117 | Power Ballad
118 | Rhythmic Soul
119 | Freestyle
120 | Duet
121 | Punk Rock
122 | Drum Solo
123 | A capella
124 | Euro-House
125 | Dance Hall
126 | Goa
127 | Drum & Bass
128 | Club-House
129 | Hardcore
130 | Terror
131 | Indie
132 | Britpop
133 | Negerpunk
134 | Polsk Punk
135 | Beat
136 | Christian Gangsta
137 | Heavy Metal
138 | Black Metal
139 | Crossover
140 | Contemporary C
141 | Christian Rock
142 | Merengue
143 | Salsa
144 | Thrash Metal
145 | Anime
146 | JPop
147 | SynthPop


AudioInformation2

NCTAudioStudio2 ActiveX DLLs

Version 2.2

NCTAudioInformation2 ActiveX DLL allows to edit information tags in an audio file.

With NCTAudioInformation2 you can:

  • Create and edit extra user information (tags) in audio files. WAV, OGG, MP3, MP2 and MP+ tags can be processed. For more information see the infoTrack, infoTitle, infoArtist, infoAlbum, infoYear, infoGenreS, infoComments, infoComposer, infoCopyright, infoURL and infoEncodedBy properties;

  • Insert and delete cues (markers) in audio files. This information is only can be saved with WAV files, that have RIFF file structure. For more information see the cueXXX properties;

  • Get general information about audio files and audio track of AVI files such as: audio format, bit rate, audio sample size (number of bits per sample), channels, audio sample rate (frequency), number of samples, time duration and size. For more information see the FormatTag, FormatString, Bitrate, BitsPerSample, Channels, Frequency, Samples, Duration and Size properties.

There is a category of audio files that has no header or any extra user information. Thus it is impossible to define their parameters (audio format, bit rate and etc.) automatically. You should know them or pick the parameters experimentally. It is always necessary to use the SetFormatXXX methods (NCTAudioFile) to operate with RAW, G.721, G.723, G.726 and VOX files, because these files without any header. The SetFormatXXX methods specify not only the OUTPUT files' format, but the INTPUT files' format too.

NCTAudioInformation2 is a part of the NCTAudioStudio2 package.

Send Feedback on the NCTAudioInformation2 documentation.
NCTAudioInformation2 was developed by NCT company http://www.nctsoft.com


NCTAUDIOINFORMATION2Lib

NCTAudioStudio2 ActiveX DLLs

Version 2.2

NCTAudioInformation2 ActiveX DLL allows to edit information tags in an audio file.

With NCTAudioInformation2 you can:

  • Create and edit extra user information (tags) in audio files. WAV, OGG, MP3, MP2 and MP+ tags can be processed. For more information see the infoTrack, infoTitle, infoArtist, infoAlbum, infoYear, infoGenreS, infoComments, infoComposer, infoCopyright, infoURL and infoEncodedBy properties;

  • Insert and delete cues (markers) in audio files. This information is only can be saved with WAV files, that have RIFF file structure. For more information see the cueXXX properties;

  • Get general information about audio files and audio track of AVI files such as: audio format, bit rate, audio sample size (number of bits per sample), channels, audio sample rate (frequency), number of samples, time duration and size. For more information see the FormatTag, FormatString, Bitrate, BitsPerSample, Channels, Frequency, Samples, Duration and Size properties.

There is a category of audio files that has no header or any extra user information. Thus it is impossible to define their parameters (audio format, bit rate and etc.) automatically. You should know them or pick the parameters experimentally. It is always necessary to use the SetFormatXXX methods (NCTAudioFile) to operate with RAW, G.721, G.723, G.726 and VOX files, because these files without any header. The SetFormatXXX methods specify not only the OUTPUT files' format, but the INTPUT files' format too.

NCTAudioInformation2 is a part of the NCTAudioStudio2 package.

Send Feedback on the NCTAudioInformation2 documentation.
NCTAudioInformation2 was developed by NCT company http://www.nctsoft.com